O que é variável e constante?

Programas de computador utilizam os recursos de hardware mais básicos para executar algoritmos. Enquanto o processador executa os cálculos, a memória é responsável por armazenar dados e servi-los ao processador. O recurso utilizado nos programas para escrever e ler dados da memória do computador é conhecido como variável, que é simplesmente um espaço na memória o qual reservamos e damos um nome. Por exemplo, podemos criar uma variável chamada “idade” para armazenar a idade de uma pessoa. Você pode imaginar uma variável como uma gaveta “etiquetada” em um armário.

gaveta

Quando criamos uma variável em nosso programa especificamos que tipo de dados pode ser armazenado nela (dependendo da linguagem de programação). Por exemplo, a variável nome só poderia armazenar valores do tipo texto. Já a variável idade, só poderia armazenar valores do tipo número (inteiro).

Chamamos este espaço alocado na memória de variável, porque o valor armazenado neste espaço de memória pode ser alterado ao longo do tempo, ou seja, o valor ali alocado é “variável” ao longo do tempo. Diferente das constantes, que é um espaço reservado na memória para armazenar um valor que não muda com o tempo. Por exemplo, o valor PI (3.14159265359…) que nunca vai mudar!

Veja como funciona uma variável com um algoritmo

Para não restar dúvidas, vamos mostrar como funciona uma variável em um algoritmo.

Algoritmo Teste de Variável

Declaração das variáveis

nome : Texto

Inicio

nome <- “João”

imprimir(nome)

nome <- “Maria”

imprimir(nome)

Fim

Neste algoritmo, declaramos uma variável chamada “nome” do tipo “Texto”. Inicialmente armazenamos o texto “João” na variável nome, e mandamos imprimir na tela o valor desta variável. Neste momento aparece na tela o texto “João”, em seguida alteramos o valor da variável para “Maria” neste momento o texto “João” é apagado da memória e em seu lugar é armazenado o texto “Maria”. Em seguida, mandamos imprimir na tela novamente o valor da variável, então aparece na tela o texto “Maria”.

Só mais um exemplo pra garantir. rs

Algoritmo Soma

Declaração de variáveis

numero1 : Inteiro

numero2: Inteiro

resultado: Inteiro

Inicio

numero1 <- 5

numero2 <- 4

resultado <- numero1 + numero2

imprimir(resultado)

numero2 <- 2

resultado <- resultado * numero2

imprimir(resultado)

Fim

O resultado deste algoritmo é imprimir na tela o valor “9″ e depois o valor “18″. Ainda resta dúvidas?

Saber como ler e escrever dados na memória do computador é muito importante para criar um algoritmo. E a forma como fazemos isso é através das variáveis.


Acompanhe o { Dicas de Programação } curtindo nossa página no Facebook e seguindo-nos no Twitter!

Pin It

21 thoughts on “O que é variável e constante?

  1. Olá Gustavo. estou com um problema no meu trabalho de situação de aprendizagem.
    fiz o menu no visual G mas não consigo que o menu puxe cadastro de produto, cadastro de categoria…etc usei o Se e no final de cada Se o fimse só que ao digitar o numero referente ao cadastro de produto ex: 2 ou 1 ele da fim de execução POIS TEM UM Fimse. estou tentando usar procedimento não consegui.
    que posso fazer?
    Se vc puder mandar um exemplo de um Menu que continua cadastrando produtos, categorias e outros

      • Gustavo continuo na mesma! usei mas não sei se usei correto “coisa de iniciante” estou passando para ti dar uma olha? se possível. Ok
        Se eu conseguir fazer essa primeira parte eu consigo fazer o Restante

        Escreval(“Digite 1 para cadastro de Produtos:”)
        Escreval(“Digite 2 para cadastro de Categoria:”)
        Escreval(“Digite 3 Para cadastro de Respónsavel Técnico:”)
        Escreval(“Digite 4 para cadastro de Clientes:”)
        Escreval(“Digite 5 para cadastro de Plano de Prevenção:”)
        Escreval(“Digite 6 para cadastro do Detalhamento do Plano:”)
        Escreval(“Digite 0 para Sair do Programa:”)
        Leia(opcaoUsuario)
        Se (OpcaoUsuario = “0″) entao
        Escreva (“Finalizando o Programa…”)
        Fimse
        Escolha CadastroDeProdutos
        Caso faca
        “ir para cadastro de produto” =
        caso faca
        “Ir para Cadastro de categoria” =
        Caso faca
        “Ir para cadastro de Responsavel Técinco” =
        Caso faca
        “Ir para cadastro de Clientes” =
        Caso faca
        “Ir para cadastro do plano de prevenção” =
        Caso faca
        “Ir para cadastro do detalhamento do plano” =
        Fimescolha
        //cadastro de Produto
        procedimento cadastroDeProduto ()
        Var
        codigoProduto, codigoInformado: Inteiro
        nomeProduto, descricaoProduto: Caracter
        valorProduto: Real
        codigoProduto <- codigoProduto + 1
        Inicio
        Escreva("Informe o nome para o produto*:")
        Leia(nomeProduto)
        Se nomeProduto = " " entao

        Grato;
        Att:
        José Dias.

    • Olá Gustavo volto aqui para ti agradecer pelas dicas já estou programando em C agora entendi que tem que correr atrás e estudar bastante senão não consegui.
      apresentei uma trabalho essa semana no Dev C++ sei que tenho muito a aprender ainda.
      mas muito obrigado mesmo

      Grato
      Att
      José Dias

  2. Escreval(“Digite 1 para cadastro de Produtos:”)
    Escreval(“Digite 2 para cadastro de Categoria:”)
    Escreval(“Digite 3 Para cadastro de Respónsavel Técnico:”)
    Escreval(“Digite 4 para cadastro de Clientes:”)
    Escreval(“Digite 5 para cadastro de Plano de Prevenção:”)
    Escreval(“Digite 6 para cadastro do Detalhamento do Plano:”)
    Escreval(“Digite 0 para Sair do Programa:”)
    Leia(opcaoUsuario)
    Se (OpcaoUsuario = “0″) entao
    Escreva (“Finalizando o Programa…”)
    Fimse
    Escolha CadastroDeProdutos
    Caso faca
    “ir para cadastro de produto” =
    caso faca
    “Ir para Cadastro de categoria” =
    Caso faca
    “Ir para cadastro de Responsavel Técinco” =
    Caso faca
    “Ir para cadastro de Clientes” =
    Caso faca
    “Ir para cadastro do plano de prevenção” =
    Caso faca
    “Ir para cadastro do detalhamento do plano” =
    Fimescolha
    //cadastro de Produto
    procedimento cadastroDeProduto ()
    Var
    codigoProduto, codigoInformado: Inteiro
    nomeProduto, descricaoProduto: Caracter
    valorProduto: Real
    codigoProduto <- codigoProduto + 1
    Inicio
    Escreva("Informe o nome para o produto*:")
    Leia(nomeProduto)
    Se nomeProduto = " " entao

  3. Gustavo está copiando errado no envio até o fimse esta certo, o programa executa mas para puxar os outros (Conector de outra pagina) que não tem no visualg. tenta enviar como eu puxaria o cadastro de produto e os outros que eu não te incomodo mais
    Comprei o livro ai no teu Site Logica de programação mas ele começou em HTML acho que nesse momento pode servir um pouco mais pra frente sim

    Grato;
    Att:
    José Dias.

    • José, você tá quase pegando a ideia da coisa. É o seguinte … Você pode utilizar a estrutura ESCOLHA-CASO, assim:

      1. IMPRIMIR O MENU DE OPÇÕES, ou seja, “Digite 1 para Produtos”, “Digite 2 para …”, etc
      2. Ler a opção digitada, atribuir na variável opcaoUsuario:
      3. Aqui começa a estrutura ESCOLHA-CASO, nessa estrutura, você deve especificar a variável que será testada e indicar a sequencia a ser seguida em cada caso, veja:

      ESCOLHA opcaoUsuario
      CASO 1 FAÇA
      sequência de código a ser executada caso opcaoUsuario = 1, ou seja (cadastro de Produtos)…
      CASO 2 FAÇA
      sequência de código a ser executada caso opcaoUsuario = 2.

      E assim por diante…

      Fimescolha

      Para entender melhor a estrutura ESCOLHA-CASO, leia atentamente este post.

      Ah, quanto ao livro, se for o livro de lógica de programação da editora Casa do código, sugiro que continue lendo … Ele é muito bom, ele começa a falar de HTML porque ensina lógica de programação com javascript, mas o objetivo do livro é ensinar lógica de programação mesmo.

      Um abraço e bons estudos!

    • Wendel, como política do { Dicas de Programação }, não resolvemos exercícios. Se tiver alguma dúvida, eu posso te ajudar, mas não resolvo exercício pra ninguém …

      Já ajudei muitas pessoas aqui, seja por comentário ou por e-mail, mas sempre tirando dúvida, explicando a forma correta e a errada. Mas o mínimo que você tem que fazer é tentar resolver o exercício sozinho.

  4. Olá Gustavo,
    Primeiramente quero agradecer pelo seu trabalho em ajudar iniciantes como eu.
    Observando o último algoritmo surgiu uma dúvida, o (imprimir) não seria uma variável também?
    Tentei executar, porém me retorna a mensagem “dizendo variável não encontrada”. Pensei! É só acrescentar o imprimir como variável, porém, surgi outro erro ” sintaxe incorreta”.

    Pode me ajudar com essa dúvida, estou tento contato com o Visualg pela primeira vez.

    Agradeço pela atenção!
    Boa noite!

    • Oi Poliana. Fico feliz em poder te ajudar a aprender.

      O imprimir do último exemplo é na verdade um PROCEDIMENTO e não uma variável. Leia este artigo que você vai entender: http://www.dicasdeprogramacao.com.br/o-que-sao-funcoes-e-procedimentos/

      Mais uma coisa, o exemplo é só um pseudo-código, ou seja, não foi escrito pra rodar no visualg.

      Pra rodar no Visualg, o algoritmo ficaria mais ou menos assim:
      algoritmo “teste_variavel”
      var
      numero1 : Inteiro
      numero2: Inteiro
      resultado: Inteiro
      inicio
      numero1 := 5
      numero2 := 4
      resultado := numero1 + numero2
      escreval(resultado)
      numero2 := 2
      resultado := resultado * numero2
      escreva(resultado)
      fimalgoritmo

      Espero que ajude! Um abraço!

    • Leonardo, obrigado pelo comentário.

      É numero2 mesmo. O objetivo do algoritmo é justamente explicar que o valor da variável numero2 pode mudar ao longo da execução do programa.

      Um abraço!

Deixe uma resposta